G.Skill RipJawsZ 16GB 2400mhz X79 memory (F3-19200CL11Q-16GBZHD)

Review Score:
7 Flares 7 Flares ×

On this page we present some super high resolution images of the product taken with the 24.5MP Nikon D3X camera and 24-70mm ED lens. These will take much longer to open due to the dimensions, especially on slower connections. If you use these pictures on another site or publication, please credit Kitguru.net as the owner/source.

ACC 7156 300x200 G.Skill RipJawsZ 16GB 2400mhz X79 memory (F3 19200CL11Q 16GBZHD)

ACC 71541 300x200 G.Skill RipJawsZ 16GB 2400mhz X79 memory (F3 19200CL11Q 16GBZHD)ACC 71581 300x200 G.Skill RipJawsZ 16GB 2400mhz X79 memory (F3 19200CL11Q 16GBZHD)

ACC 71621 300x200 G.Skill RipJawsZ 16GB 2400mhz X79 memory (F3 19200CL11Q 16GBZHD)ACC 71642 300x200 G.Skill RipJawsZ 16GB 2400mhz X79 memory (F3 19200CL11Q 16GBZHD)

ACC 71682 300x200 G.Skill RipJawsZ 16GB 2400mhz X79 memory (F3 19200CL11Q 16GBZHD)ACC 71701 300x200 G.Skill RipJawsZ 16GB 2400mhz X79 memory (F3 19200CL11Q 16GBZHD)

ACC 71742 300x200 G.Skill RipJawsZ 16GB 2400mhz X79 memory (F3 19200CL11Q 16GBZHD)ACC 71761 300x200 G.Skill RipJawsZ 16GB 2400mhz X79 memory (F3 19200CL11Q 16GBZHD)

ACC 71781 300x200 G.Skill RipJawsZ 16GB 2400mhz X79 memory (F3 19200CL11Q 16GBZHD)ACC 71801 300x200 G.Skill RipJawsZ 16GB 2400mhz X79 memory (F3 19200CL11Q 16GBZHD)

ACC 7181 300x200 G.Skill RipJawsZ 16GB 2400mhz X79 memory (F3 19200CL11Q 16GBZHD)ACC 71851 300x200 G.Skill RipJawsZ 16GB 2400mhz X79 memory (F3 19200CL11Q 16GBZHD)

VN:R_U [1.9.22_1171]
Rating: 5.0/5 (1 vote cast)
G.Skill RipJawsZ 16GB 2400mhz X79 memory (F3-19200CL11Q-16GBZHD), 5.0 out of 5 based on 1 rating
7 Flares Google+ 0 Twitter 6 Reddit 0 StumbleUpon 1 Email -- Facebook 0 7 Flares ×

Page : 1 2 3 4 5 6 7 8 9 10

  • Jeff

    Awesome, especially for the capacity. dont they also sell 32gb and 64gb kits?

    VA:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • Brooke

    X79 is astounding, but the price of this platform is out of my range. im quite happy with the 2500k. Memory bandwidth is incredible, no doubt about it.

    VA:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • Davis

    They make great memory, but it can be hard to find here even if I wanted it. crucial are everywhere.

    VA:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • Frankie

    They could make the memory better looking, as little as that means, it is something corsair do great. Performance wise, its certainly impressive. small audience for X79 thought I would think.

    VA:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • Pingback: News for December 13th 2011()

  • Pingback: IT News And Reviews – Still running Nehalem or Westmere? Maybe it is time for a memory upgrade.()

  • Pingback: Tuesday News, December 13th 2011()

  • Pingback: The News: Monkey Day Edition | MEGATechNews()

  • Pingback: ★ MacPReview ★ - Overclock King? The Asrock X79 Extreme9 LGA2011 mobo -()

  • Paul

    Hi, because of the preview I brought exactly the same configuration to prevent problems and because the author is very positive about this configuration. Although CPU-Z 1.59 shows 16 GB, Windows x64 Ultimate (and all other testprogramms) only show 12 GB. How can I fix this? I have upgraded my BIOS to 0901 (because of memory issues) but nothing helps. Paul Jansen, The Netherlands.

    VA:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • http://www.kitguru.net Zardon

    just to confirm, you are using the Asus Rampage motherboard as in the review? I am not at a local machine to check bios revisions…………

    can you list your full system hardware build?

    VN:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • Paul

    @Zardon, I’m using the Asus Rampage IV Extreme as in the preview. Somehow the motherbord just died that day, it won’t boot after I changed some overclock settings. Also switching to BIOS 2, clearing and removal of battery, nothing helped. The moment you press on, the fan on the bord stops after 0,2 sec or so, maybe a shortcurcuit? Of course I changed RAM/VGA/PSU and disconnect SSD’s/CDROM but it stays dead. I’ve send the board back, the new one arrived a few days ago. Today I’ll try to set everything up again and see how this board performs.

    VA:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • http://www.kitguru.net Zardon

    Sounds like a bit of a disaster. I hope this one works out better for you. Let me know how you get on.

    VN:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • Paul

    @Zardon, again bad news! The second ASUS Rampage IV Extreme failed to start up right out of the box. This time I’ve send the CPU/Board/RAM to the shop. The Intel Core i7 3960X is dead. Tomorrow the new CPU will arrive, they will test it first on a new board and then in mine. I’m not sure if they have tested my 16 GB G.Skill kit already. I’m a pc ‘addict’ since 1985 (8080) but this kind of bad luck I’ve never experienced before :-( !

    VA:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • http://www.kitguru.net Zardon

    Hi Paul. Wow that’s terrible luck :( You don’t often hear of a DOA Intel processor, but I am sure it does happen. Glad you got a replacement without a problem. Did you order this all from the same store?

    VN:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • Paul

    Hi Zardon. The CPU and the board are from the same store, the RAM is from another store but they were willing to test all three to be sure. There are a few options, maybe the first board fried the CPU and after they replaced the board the CPU fried the second board!? Because I was not sure about the RAM and I had no possibility to test (my old ASUS Maximus Extreme can only address 2 GB modules), I had to send all three in. I read on the net that GigaByte had also X79 problems (CPU power stability) and the new MSI X79 board had extra attention to the CPU power as well (oversized CPU power modules). But it is pure speculation that my ASUS/Intel problems have something to do with this issue, I don’t read anything about the Rampage IV Extreme and/or 3960X on the net. Grtz, Paul.

    VA:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • Paul

    Finally everything is working again! 1st time the ASUS Rampage IV Extreme was dead after a few days, the 2nd time the CPU was DOA (had sold the 1st one during the RMA procedure of the board). Still I have the memory issue though. KitGuru please help, I have EXACTLY the same configuration as in your test but Windows only shows 12 GB instead of 16 GB. ASUS just released the 4th BIOS (version 1101 of january 11th) and still it shows 12 GB although only CPU-Z shows 16 GB. As ASUS recommended, I used the red DIMM sockets for the 4×4 GB G.Skill RipJawsZ 2400 MHz modules.

    VA:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • http://www.kitguru.net Zardon

    Hi paul glad to hear you have it working. When you say windows only shows 12gb, where are you checking this? Third party software or?

    Does the bios show 16gb in quad channel? What timings are you using?

    Does sisoft sandra show 16gb? And are you getting around 50gbs in the memory test?

    What version of windows are you using?

    VN:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • Paul

    One of the memory modules is not working! It is a matched quad channel 4×4 GB kit like KitGuru tested here. I just tested one module at a time in every slot (this takes HOURS because I want the board to be without any voltage the moment I swap dimms and there are 8 dimm slots and 4 modules and a PSU which holds it’s power too long for this type of testing). The strange thing is, Windows 7 Ultimate x64 shows 12 GB (so also the Windows swap file is 12 GB), Everest Ultimate shows 12 GB but CPU-Z detects 16 GB and shows of course 4 dimms of 4 GB in use. So, the best thing was one module in one slot. Finally every time this same module doesn’t boot, every other module starts in every of the 8 dimm slots. When I combine the good modules, Windows shows the correct amount of 4, 8 or 12 GB. The wrong module doesn’t work in which ever dimm slot I try. I didn’t try different timing/frequency settings or voltages, I just selected X.M.P. profile 1 which should be ok. These are the default G.Skill RipJawsZ settings like the above KitGuru test. The ASUS Rampage IV Extreme can go even higher than 2500 MHz (BIOS indicates) so this is not a problem. All in all this is the 3rd time I have to sent something back for repairs, a dead MB after 2 days, a DOA 3960X cpu and now a RAM module. Nice (NOT!!!). By the way, the first MB showed also 12 GB before it went dead so I didn’t fry the module or so. The only thing, I didn’t connect the extra RAM power cable, the first time, now I do. I didn’t because I only use 4 instead of 8 modules, the manual shows it is better for stability so I’ve connected extra power now to be sure.

    VA:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • http://www.kitguru.net Zardon

    Oh dear, you haven’t had much luck with this. Can you get the ram replaced ok?

    VN:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • Paul

    Zardon, I’ve just send my ram to the seller. Because it is Saturday tomorrow, they will receive it but that’s all I guess. I’ll hear from them next week, that’s normal. Let’s wait and see. Now I’m testing the board, the cpu is stable at the lowest OC-profile which is 4,375 Mhz @62C and I’m using 2×2 GB old OCZ PC 16000 memory @ 1,666 Mhz right now. Very nice are the two Plextor’s M2P 256 GB in RAID 0. Every test is above 1 GB/sec and HD Tune Pro shows even a burstspeed of 4.5 GB/s!!! In Win7 the cpu shows 7.8, the G.Skill ram showed 7.9 and the ssd’s show 7.9 as well. Win7 can’t even show higher as 7.9 so I’m happy to see this. BTW, the system doesn’t start that fast, probably Win7 prevents that or the BIOS has wait loops or so. It still takes about 40 sec to completely start up.

    VA:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • http://www.kitguru.net Zardon

    What cooler are you using on it?

    VN:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • Paul

    I’m still using the good old Scythe Mugen 2 Rev.B. Although EOL by now you can still get them here in the Netherlands (€32). The new version 3 is not as quiet and does a less cooling job so I’m very pleased with the “old” one! The Mugen 2 is not designed for a LGA2011 socket but it fits perfectly when in use with the LGA 1366 plate/holes. The ASUS Rampage IV Extreme comes with a special groundplate adapter so you can mount an old style LGA 1155/1156/1366 cooler but in the case of the Mugen 2 Rev.B this is unnesserary. I’ve tried the cpu @4,500 MHz now for a night, perfectly stable and in Idle @66C but under 100% load it gets 80C. I used Zalman ZM-STG2 thermal grease (‘in a hurry’). Today I’ll clean everything with Isopropanol very thoroughly and apply Artic MX-4 thermal grease according the instructions on there site (they describe different a application for different processors). Let’s see if this has a possitive effect although 80C under max. load (6 cores @ 100% load @ 4,500 MHz for hours) is not too bad.

    VA:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • Paul

    I’m still using the good old Scythe Mugen 2 Rev.B. Although EOL by now you can still get them here in the Netherlands. The new version 3 is not as quiet and does a less cooling job so I’m very pleased with the “old” one! The Mugen 2 is not designed for a LGA2011 socket but it fits perfectly when in use with the LGA 1366 plate/holes. The ASUS Rampage IV Extreme comes with a special groundplate adapter so you can mount an old style LGA 1155/1156/1366 cooler but in the case of the Mugen 2 Rev.B this is unnesserary. I’ve tried the cpu @4,500 MHz now for a night, perfectly stable and in Idle @66C but under 100% load it gets 78C. I used Zalman ZM-STG2 thermal grease (‘in a hurry’). Today I’ll clean everything with Isopropanol very thoroughly and apply Arctic MX-4 thermal grease according the instructions on there site (they describe different applications for different processors). Let’s see if this has a possitive effect although 78C under max. load (6 cores @ 100% load @ 4,500 MHz for hours) is not too bad. The G.Skill ram is at the store now, let’s wait what they say about the faulty module…

    VA:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • Paul

    Sorry, #23 can go. The answer was nog completed so I had to change. After moderation #25 can go too to keep it clean :-).

    VA:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
  • Paul

    Finally everything works fine. Ciao, Paul.

    VA:R_U [1.9.22_1171]
    Rating: 0 (from 0 votes)
Polls

Which monitor next?

View Results

Loading ... Loading ...
KitGuru Facebook
Latest News Latest Previews
Related Posts
Archives