<!DOCTYPE html>
<html lang=en-US prefix="og: http://ogp.me/ns#">
<head>
<meta charset=UTF-8 />
<meta name=google-site-verification content=o0aRnOSSiRIVA-ZV8rQMHSwMFKc3aOhZjsGG3B5aBwg />
<link rel=profile href="http://gmpg.org/xfn/11"/>
<link rel=pingback href="https://www.kitguru.net/xmlrpc.php"/>
<title>GeIL Launches EVO SPEAR Phantom Gaming Edition DDR4 memory | KitGuru</title>
<meta property=og:title content="GeIL Launches EVO SPEAR Phantom Gaming Edition DDR4 memory - KitGuru"/>
<meta property=og:type content=article />
<meta property=og:description content="Golden Emperor International Ltd, the company more commonly known as GeIL has announced the availabi"/>
<meta property=og:url content="https://www.kitguru.net/components/memory/james-dawson/geil-launches-evo-spear-phantom-gaming-edition-ddr4-memory/"/>
<meta property=og:site_name content=KitGuru />
<meta property=og:image content="https://www.kitguru.net/wp-content/uploads/2020/02/MjFr96vJmwRb7hI5-732x330.jpg"/>
<meta name=description content="Golden Emperor International Ltd, the company more commonly known as GeIL has announced the availability from retailers in the Americas of its new EVO SPEAR"/>
<meta name=keywords content="ddr4 memory,evo spear,geil,news,phantom gaming edition,ram"/>
<script data-pagespeed-no-defer>//<![CDATA[
(function(){function d(b){var a=window;if(a.addEventListener)a.addEventListener("load",b,!1);else if(a.attachEvent)a.attachEvent("onload",b);else{var c=a.onload;a.onload=function(){b.call(this);c&&c.call(this)}}}var p=Date.now||function(){return+new Date};window.pagespeed=window.pagespeed||{};var q=window.pagespeed;function r(){this.a=!0}r.prototype.c=function(b){b=parseInt(b.substring(0,b.indexOf(" ")),10);return!isNaN(b)&&b<=p()};r.prototype.hasExpired=r.prototype.c;r.prototype.b=function(b){return b.substring(b.indexOf(" ",b.indexOf(" ")+1)+1)};r.prototype.getData=r.prototype.b;r.prototype.f=function(b){var a=document.getElementsByTagName("script"),a=a[a.length-1];a.parentNode.replaceChild(b,a)};r.prototype.replaceLastScript=r.prototype.f;
r.prototype.g=function(b){var a=window.localStorage.getItem("pagespeed_lsc_url:"+b),c=document.createElement(a?"style":"link");a&&!this.c(a)?(c.type="text/css",c.appendChild(document.createTextNode(this.b(a)))):(c.rel="stylesheet",c.href=b,this.a=!0);this.f(c)};r.prototype.inlineCss=r.prototype.g;
r.prototype.h=function(b,a){var c=window.localStorage.getItem("pagespeed_lsc_url:"+b+" pagespeed_lsc_hash:"+a),f=document.createElement("img");c&&!this.c(c)?f.src=this.b(c):(f.src=b,this.a=!0);for(var c=2,k=arguments.length;c<k;++c){var g=arguments[c].indexOf("=");f.setAttribute(arguments[c].substring(0,g),arguments[c].substring(g+1))}this.f(f)};r.prototype.inlineImg=r.prototype.h;
function t(b,a,c,f){a=document.getElementsByTagName(a);for(var k=0,g=a.length;k<g;++k){var e=a[k],m=e.getAttribute("data-pagespeed-lsc-hash"),h=e.getAttribute("data-pagespeed-lsc-url");if(m&&h){h="pagespeed_lsc_url:"+h;c&&(h+=" pagespeed_lsc_hash:"+m);var l=e.getAttribute("data-pagespeed-lsc-expiry"),l=l?(new Date(l)).getTime():"",e=f(e);if(!e){var n=window.localStorage.getItem(h);n&&(e=b.b(n))}e&&(window.localStorage.setItem(h,l+" "+m+" "+e),b.a=!0)}}}
function u(b){t(b,"img",!0,function(a){return a.src});t(b,"style",!1,function(a){return a.firstChild?a.firstChild.nodeValue:null})}
q.i=function(){if(window.localStorage){var b=new r;q.localStorageCache=b;d(function(){u(b)});d(function(){if(b.a){for(var a=[],c=[],f=0,k=p(),g=0,e=window.localStorage.length;g<e;++g){var m=window.localStorage.key(g);if(!m.indexOf("pagespeed_lsc_url:")){var h=window.localStorage.getItem(m),l=h.indexOf(" "),n=parseInt(h.substring(0,l),10);if(!isNaN(n))if(n<=k){a.push(m);continue}else if(n<f||!f)f=n;c.push(h.substring(l+1,h.indexOf(" ",l+1)))}}k="";f&&(k="; expires="+(new Date(f)).toUTCString());document.cookie=
"_GPSLSC="+c.join("!")+k;g=0;for(e=a.length;g<e;++g)window.localStorage.removeItem(a[g]);b.a=!1}})}};q.localStorageCacheInit=q.i;})();
pagespeed.localStorageCacheInit();
//]]></script><link rel=stylesheet id=alek_hacks_overrides-css href='https://www.kitguru.net/wp-content/plugins/alek_mpu/overrides.css' type='text/css' media=all /><link rel=stylesheet id=tie-insta-style-css href='https://www.kitguru.net/wp-content/plugins/instagramy/assets/style.css' type='text/css' media=all /><link rel=stylesheet id=wp-polls-css href='https://www.kitguru.net/wp-content/plugins/wp-polls/polls-css.css' type='text/css' media=all /><link rel=stylesheet id=gdrts-gridism-css href='https://www.kitguru.net/wp-content/plugins/gd-rating-system/css/gridism.css' type='text/css' media=all /><style>.gdrts-stars-rating:not(.gdrts-state-active){cursor:default}.gdrts-stars-rating.gdrts-state-active .gdrts-stars-empty:not(.gdrts-vote-saving){cursor:pointer}.gdrts-thumbs-rating:not(.gdrts-state-active) .gdrts-thumb-down,.gdrts-thumbs-rating:not(.gdrts-state-active) .gdrts-thumb-up{cursor:default}.gdrts-thumbs-rating.gdrts-state-active:not(.gdrts-vote-saving) .gdrts-thumb-down,.gdrts-thumbs-rating.gdrts-state-active:not(.gdrts-vote-saving) .gdrts-thumb-up{cursor:pointer}.gdrts-thumbs-rating.gdrts-state-active:not(.gdrts-vote-saving).gdrts-with-image .gdrts-thumb-up:hover .gdrts-thumb-image{background-position:left top}.gdrts-thumbs-rating.gdrts-state-active:not(.gdrts-vote-saving).gdrts-with-image .gdrts-thumb-down:hover .gdrts-thumb-image{background-position:right top}.gdrts-thumbs-theme-plain.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-thumb:hover{color:#fff}.gdrts-thumbs-theme-plain.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-thumb.gdrts-thumb-up:hover{background:#0a0}.gdrts-thumbs-theme-plain.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-thumb.gdrts-thumb-down:hover{background:#a00}.gdrts-thumbs-theme-plain-inline.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-thumb:hover{color:#fff}.gdrts-thumbs-theme-plain-inline.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-thumb.gdrts-thumb-up:hover{background:#0a0}.gdrts-thumbs-theme-plain-inline.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-thumb.gdrts-thumb-down:hover{background:#a00}.gdrts-thumbs-theme-simple.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-thumb.gdrts-thumb-up:hover{color:#0a0}.gdrts-thumbs-theme-simple.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-thumb.gdrts-thumb-down:hover{color:#a00}.gdrts-thumbs-theme-compact.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-thumb.gdrts-thumb-up:hover .gdrts-thumb-link{color:#8f8}.gdrts-thumbs-theme-compact.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-thumb.gdrts-thumb-down:hover .gdrts-thumb-link{color:#f88}.gdrts-like-this:not(.gdrts-state-active) .gdrts-like .gdrts-like-link{cursor:default}.gdrts-like-this.gdrts-state-active:not(.gdrts-vote-saving) .gdrts-like .gdrts-like-link{cursor:pointer}.gdrts-like-this:not(.gdrts-loop-saving) .gdrts-like-link.gdrts-like-hover:hover .gdrts-liked-symbol{display:none!important}.gdrts-like-this:not(.gdrts-loop-saving) .gdrts-like-link.gdrts-like-hover:hover .gdrts-clear-symbol{display:inline-block!important}.gdrts-like-this.gdrts-state-active.gdrts-with-image:not(.gdrts-vote-saving) .gdrts-like:hover .gdrts-like-symbol .gdrts-like-image{background-position:0 100%}.gdrts-likes-theme-simple.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-like:hover .gdrts-like-link{color:#0a0}.gdrts-likes-theme-standard.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-like:hover .gdrts-like-link{color:#8f8}.gdrts-likes-theme-standard.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-like:hover .gdrts-like-link.gdrts-like-hover{color:#f88}.gdrts-likes-theme-expanding.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-like:hover .gdrts-like-link{color:#8f8}.gdrts-likes-theme-expanding.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-like:hover .gdrts-like-link.gdrts-like-hover{color:#f88}.gdrts-likes-theme-balloon.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-like:hover .gdrts-like-link{color:#8f8}.gdrts-likes-theme-balloon.gdrts-state-active:not(.gdrts-vote-saving):not(.gdrts-with-image) .gdrts-like:hover .gdrts-like-link.gdrts-like-hover{color:#f88}.gdrts-rating-list table tr:nth-of-type(2n){background:#fafafa}.gdrts-emote-this:not(.gdrts-state-active) .gdrts-emote-element-icon{cursor:default}.gdrts-emote-this.gdrts-state-active .gdrts-emote-element-icon:not(.gdrts-vote-saving){cursor:pointer}</style><link rel=stylesheet id=gdrts-font-css href='https://www.kitguru.net/wp-content/plugins/gd-rating-system/font/default.min.css' type='text/css' media=all /><link rel=stylesheet id=gdrts-tooltip-css href='https://www.kitguru.net/wp-content/plugins/gd-rating-system/addons/tooltip/css/tooltip.css' type='text/css' media=all /><link rel=stylesheet id=tie-style-css href='https://www.kitguru.net/wp-content/themes/sahifa/style.css' type='text/css' media=all /><link rel=stylesheet id=tie-ilightbox-skin-css href='https://www.kitguru.net/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media=all /><link rel=stylesheet id='Open+Sans-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic' type='text/css' media=all /><link rel=stylesheet id='Droid+Sans-css' href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media=all /><link rel=stylesheet id=js_composer_custom_css-css href='//www.kitguru.net/wp-content/uploads/js_composer/custom.css' type='text/css' media=all /><style media=screen>.g{margin:0;padding:0;overflow:hidden;line-height:1;zoom:1}.g img{height:auto}.g-1{margin:1px;1px 1px 1px}.g-2{margin:1px;1px 1px 1px}.g-3{margin:1px;1px 1px 1px}.g-4{margin:1px;1px 1px 1px}.g-5{margin:1px 1px 1px 1px}.g-6{margin:1px;1px 1px 1px}.g-14{margin:1px 1px 1px 1px}.g-15{margin:1px 1px 1px 1px}.g-16{margin:1px 1px 1px 1px}.g-17{margin:1px;1px 1px 1px}.g-18{margin:1px 1px 1px 1px}.g-52{margin:1px;1px 1px 1px}@media only screen and (max-width:480px){.g-single{width:100%;margin-left:0;margin-right:0}}</style><link rel=stylesheet href="https://www.kitguru.net/wp-content/plugins/search-engine-query-in-wordpress-related-contents/seq_in_wp.css" type="text/css"/><link rel=stylesheet type="text/css" href="https://www.kitguru.net/wp-content/plugins/star-rating-for-reviews/star-rating.css"/><style media=screen>body{font-family:'Open Sans'}.logo h2 a{font-family:'Open Sans'}#main-nav,#main-nav ul li a{font-family:'Open Sans'}.post-title{font-family:'Open Sans'}p.post-meta,p.post-meta a{font-family:'Open Sans'}body.single .entry{font-family:'Open Sans'}.widget-top h4{font-family:'Open Sans'}.footer-widget-top h4{font-family:'Open Sans'}.block-head h3{font-family:'Open Sans'}body{background-image:url(https://www.kitguru.net/wp-content/uploads/2020/02/Partner_Kitguru_HyperX_FURY-DDR4_site-skin_WF478822_0919.jpg)!important}body.single .post .entry a{text-decoration:underline}#wrapper,#wrapper.boxed-all{background:#f7f7f7}@media only screen and (min-width:1045px){div.wrapper-outer{top:-18px}#wrapper.boxed-all{width:1100px!important}#wrapper.boxed-all #main-content{width:1062px!important}#main-nav .container{width:1100px!important}#wrapper.boxed-all #main-content .content{width:732px!important}}.search-block{height:39px!important;padding-top:9px!important}.widget-container{border-bottom:0!important;-webkit-box-shadow:none!important;-moz-box-shadow:none!important;box-shadow:none!important;padding:0!important}.widget-top{display:none!important}.widget{margin-bottom:6px!important}.header-content{padding:0 0!important;margin:0 auto!important}body{background-attachment:fixed!important;background-position:50% 0!important}#main-nav ul li{font-size:14px!important;font-weight:bold}.e3lan-top{padding-top:14px!important}.e3lan.e3lan-top{float:initial!important}#main-nav ul li a{padding:0 18px!important}header#theme-header{margin:12px auto 0!important}#theme-header{border-top:initial!important}#sidebar{top:-10px!important}.e3lan-below_header{margin:0 auto 14px!important}.social-icons{width:142px;height:47px;display:block;float:right;margin-left:1px;color:#fff;position:relative}.fa-rss:before{padding:2px;padding-left:4px;padding-right:4px;color:#ddd}.fa-google-plus:before{padding:2px;padding-left:3px;padding-right:3px;color:#ddd}.fa-facebook:before{padding:2px;padding-left:6px;padding-right:6px;color:#ddd}.fa-twitter:before{color:#ddd;padding:2px;padding-left:2px;padding-right:2px}.select-css{display:block;font-size:14px;font-family:'Open Sans';font-weight:600;color:#444;line-height:1.3;padding:.6em 1.4em .5em .8em;width:300px;max-width:300px;box-sizing:border-box;margin:0;margin-left:1px;margin-top:-2px;border:2px solid #000;box-shadow:0 1px 0 1px rgba(0,0,0,.04);-moz-appearance:none;-webkit-appearance:none;appearance:none;background-color:#fff;background-image:url(data:image/svg+xml;charset=US-ASCII,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20width%3D%22292.4%22%20height%3D%22292.4%22%3E%3Cpath%20fill%3D%22%23007CB2%22%20d%3D%22M287%2069.4a17.6%2017.6%200%200%200-13-5.4H18.4c-5%200-9.3%201.8-12.9%205.4A17.6%2017.6%200%200%200%200%2082.2c0%205%201.8%209.3%205.4%2012.9l128%20127.9c3.6%203.6%207.8%205.4%2012.8%205.4s9.2-1.8%2012.8-5.4L287%2095c3.5-3.5%205.4-7.8%205.4-12.8%200-5-1.9-9.2-5.5-12.8z%22%2F%3E%3C%2Fsvg%3E) , linear-gradient(to bottom,#fff 0%,#fff 100%);background-repeat:no-repeat , repeat;background-position:right .7em top 50% , 0 0;background-size:.65em auto , 100%}.select-css::-ms-expand{display:none}.select-css:hover{border-color:#888}.select-css:focus{border-color:#aaa;box-shadow:0 0 1px 3px rgba(59,153,252,.7);box-shadow:0 0 0 3px -moz-mac-focusring;color:#222;outline:none}.select-css option{font-weight:normal}.footer-3c .footer-widgets-box{width:100%!important;text-align:center!important}@media only screen and (max-width:985px) and (min-width:768px){#slide-out{z-index:4!important}}@media only screen and (max-width:767px) and (min-width:480px){#slide-out{z-index:4!important}}@media only screen and (max-width:479px) and (min-width:320px){#slide-out{z-index:4!important}}</style><script type="application/ld+json" class=aioseop-schema>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.kitguru.net/#organization","url":"https://www.kitguru.net/","name":"KitGuru","sameAs":[]},{"@type":"WebSite","@id":"https://www.kitguru.net/#website","url":"https://www.kitguru.net/","name":"KitGuru","publisher":{"@id":"https://www.kitguru.net/#organization"}},{"@type":"WebPage","@id":"https://www.kitguru.net/components/memory/james-dawson/geil-launches-evo-spear-phantom-gaming-edition-ddr4-memory/#webpage","url":"https://www.kitguru.net/components/memory/james-dawson/geil-launches-evo-spear-phantom-gaming-edition-ddr4-memory/","inLanguage":"en-US","name":"GeIL Launches EVO SPEAR Phantom Gaming Edition DDR4 memory","isPartOf":{"@id":"https://www.kitguru.net/#website"},"image":{"@type":"ImageObject","@id":"https://www.kitguru.net/components/memory/james-dawson/geil-launches-evo-spear-phantom-gaming-edition-ddr4-memory/#primaryimage","url":"https://www.kitguru.net/wp-content/uploads/2020/02/MjFr96vJmwRb7hI5.jpg","width":1440,"height":960},"primaryImageOfPage":{"@id":"https://www.kitguru.net/components/memory/james-dawson/geil-launches-evo-spear-phantom-gaming-edition-ddr4-memory/#primaryimage"},"datePublished":"2020-02-08T09:38:32+00:00","dateModified":"2020-02-08T09:43:34+00:00"},{"@type":"Article","@id":"https://www.kitguru.net/components/memory/james-dawson/geil-launches-evo-spear-phantom-gaming-edition-ddr4-memory/#article","isPartOf":{"@id":"https://www.kitguru.net/components/memory/james-dawson/geil-launches-evo-spear-phantom-gaming-edition-ddr4-memory/#webpage"},"author":{"@id":"https://www.kitguru.net/author/james-dawson/#author"},"headline":"GeIL Launches EVO SPEAR Phantom Gaming Edition DDR4 memory","datePublished":"2020-02-08T09:38:32+00:00","dateModified":"2020-02-08T09:43:34+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.kitguru.net/components/memory/james-dawson/geil-launches-evo-spear-phantom-gaming-edition-ddr4-memory/#webpage"},"publisher":{"@id":"https://www.kitguru.net/#organization"},"articleSection":"Featured Tech News, Memory, DDR4 memory, EVO Spear, geil, news, Phantom Gaming Edition, ram","image":{"@type":"ImageObject","@id":"https://www.kitguru.net/components/memory/james-dawson/geil-launches-evo-spear-phantom-gaming-edition-ddr4-memory/#primaryimage","url":"https://www.kitguru.net/wp-content/uploads/2020/02/MjFr96vJmwRb7hI5.jpg","width":1440,"height":960}},{"@type":"Person","@id":"https://www.kitguru.net/author/james-dawson/#author","name":"James Dawson","sameAs":[],"image":{"@type":"ImageObject","@id":"https://www.kitguru.net/#personlogo","url":"https://secure.gravatar.com/avatar/29e08bc09361e691587a1ab76f76d608?s=96&d=wavatar&r=g","width":96,"height":96,"caption":"James Dawson"}}]}</script>
<link rel=canonical href="https://www.kitguru.net/components/memory/james-dawson/geil-launches-evo-spear-phantom-gaming-edition-ddr4-memory/"/>
<link rel=dns-prefetch href='//fonts.googleapis.com'/>
<link rel=dns-prefetch href='//s.w.org'/>
<link rel=alternate type="application/rss+xml" title="KitGuru &raquo; Feed" href="https://www.kitguru.net/feed/"/>
<link rel=alternate type="application/rss+xml" title="KitGuru &raquo; Comments Feed" href="https://www.kitguru.net/comments/feed/"/>
<link rel=alternate type="application/rss+xml" title="KitGuru &raquo; GeIL Launches EVO SPEAR Phantom Gaming Edition DDR4 memory Comments Feed" href="https://www.kitguru.net/components/memory/james-dawson/geil-launches-evo-spear-phantom-gaming-edition-ddr4-memory/feed/"/>
<script src='https://www.kitguru.net/wp-includes/js/jquery/jquery.js'></script>
<script src='https://www.kitguru.net/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script src='https://www.kitguru.net/wp-content/plugins/gd-rating-system/js/events.min.js'></script>
<link rel='https://api.w.org/' href='https://www.kitguru.net/wp-json/'/>
<link rel=EditURI type="application/rsd+xml" title=RSD href="https://www.kitguru.net/xmlrpc.php?rsd"/>
<link rel=wlwmanifest type="application/wlwmanifest+xml" href="https://www.kitguru.net/wp-includes/wlwmanifest.xml"/>
<link rel=prev title='Cyberpunk 2077 will feature plenty of handcrafted side quests' href='https://www.kitguru.net/gaming/matthew-wilson/cyberpunk-2077-will-feature-plenty-of-handcrafted-side-quests/'/>
<link rel=next title='Turtle Beach adds new colour options to its Recon 70 affordable headset series' href='https://www.kitguru.net/tech-news/featured-tech-news/james-dawson/turtle-beach-adds-new-colour-options-to-its-recon-70-affordable-headset-series/'/>
<meta name=generator content="WordPress 4.9.13"/>
<link rel=shortlink href='https://www.kitguru.net/?p=450641'/>
<link rel=alternate type="application/json+oembed" href="https://www.kitguru.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.kitguru.net%2Fcomponents%2Fmemory%2Fjames-dawson%2Fgeil-launches-evo-spear-phantom-gaming-edition-ddr4-memory%2F"/>
<link rel=alternate type="text/xml+oembed" href="https://www.kitguru.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.kitguru.net%2Fcomponents%2Fmemory%2Fjames-dawson%2Fgeil-launches-evo-spear-phantom-gaming-edition-ddr4-memory%2F&#038;format=xml"/>
<link rel="shortcut icon" href="https://www.kitguru.net/wp-content/uploads/2016/08/favicon1.ico" title=Favicon />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://www.kitguru.net/wp-content/themes/sahifa/js/html5.js"></script>
<script src="https://www.kitguru.net/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="https://www.kitguru.net/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://www.kitguru.net/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="https://www.kitguru.net/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->
<meta name=viewport content="width=device-width, initial-scale=1.0"/>
<script>
			/* <![CDATA[ */
				var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/www.kitguru.net\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/www.kitguru.net\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});
			/* ]]> */
		</script>
<meta name=generator content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.kitguru.net/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://www.kitguru.net/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--> <meta name=onesignal content=wordpress-plugin />
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.kitguru.net");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '5ba2dd13-7ae1-4a57-b44a-817a09675296';
oneSignal_options['autoRegister'] = true;
oneSignal_options['httpPermissionRequest'] = { };
oneSignal_options['httpPermissionRequest']['enable'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.kitguru.net/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['displayPredicate'] = function() {
              return OneSignal.isPushNotificationsEnabled()
                      .then(function(isPushEnabled) {
                          return !isPushEnabled;
                      });
            };
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<noscript></noscript><script>
 // (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
 // (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
 // m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
 // })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  //ga('create', 'UA-15867468-1', 'auto');
  //ga('send', 'pageview');

</script>
</head>
<body id=top class="post-template-default single single-post postid-450641 single-format-standard wpb-js-composer js-comp-ver-4.12 vc_responsive">
<div class=wrapper-outer>
<a href="https://www.cclonline.com/page/hyperx-fury-ddr4/?utm_source=kitguru&#038;utm_medium=banner&#038;utm_campaign=fury_ddr4_ref" target=_blank class=background-cover></a>
<aside id=slide-out>
<div class=search-mobile>
<form id=searchform-mobile action="https://www.kitguru.net/">
<button class=search-button type=submit value=Search><i class="fa fa-search"></i></button>
<input type=text id=s-mobile name=s title=Search value=Search onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"/>
</form>
</div>
<div class=social-icons>
<a class=ttip-none title=Rss href="https://www.kitguru.net/feed/" target=_blank><i class="fa fa-rss"></i></a><a class=ttip-none title=Facebook href="https://www.facebook.com/pages/KitGuru/162236020510911?fref=ts" target=_blank><i class="fa fa-facebook"></i></a><a class=ttip-none title=Twitter href="http://twitter.com/kitgurupress" target=_blank><i class="fa fa-twitter"></i></a><a class=ttip-none title=instagram href="https://www.instagram.com/kitguru_tech/?hl=en" target=_blank><i class="fa fa-instagram"></i></a>
</div>
<div id=mobile-menu></div>
</aside>
<div id=wrapper class=boxed-all>
<div class=inner-wrapper>
<header id=theme-header class=theme-header>
<div class=header-content>
<a id=slide-out-open class=slide-out-open href="#"><span></span></a>
<div class=logo style="margin-top:15px;margin-bottom:15px">
<h2>	<a title=KitGuru href="https://www.kitguru.net/">
<img src="https://www.kitguru.net/wp-content/uploads/2017/01/kg_logo3.png" alt=KitGuru /><strong>KitGuru Kitguru.net &#8211; Tech News | Hardware News | Hardware Reviews | IOS | Mobile | Gaming | Graphics Cards</strong>
</a>
</h2>	</div>
<div class="e3lan e3lan-top">	<div class="g g-2"><div class="g-single a-1816"><a class=gofollow data-track="MTgxNiwyLDEsMTA=" href="https://msi.gm/Alpha-15-A3DX-UK" target=_blank id=href-ad-1816><img src="https://www.kitguru.net/wp-content/uploads/2019/12/MSI-Dec-728.jpg"/></a></div></div>	</div>
<div class=clear></div>
</div>
<nav id=main-nav class=fixed-enabled>
<div class=container>
<div class=main-menu><ul id=menu-home class=menu><li id=menu-item-320050 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-320050"><a href="http://www.kitguru.net"><i class="fa fa-home"></i>Home</a></li>
<li id=menu-item-298684 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-298684"><a href="http://www.kitguru.net/tag/news/">News</a></li>
<li id=menu-item-298685 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-298685"><a href="https://www.kitguru.net/reviews/">Reviews</a></li>
<li id=menu-item-301239 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-301239"><a href="https://www.kitguru.net/category/gaming/">Gaming</a></li>
<li id=menu-item-301240 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-301240"><a href="https://www.kitguru.net/category/lifestyle/mobile/">Mobile</a></li>
<li id=menu-item-410399 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-410399"><a href="https://www.kitguru.net/news/best-pc-hardware/">Best Hardware Guide</a></li>
</ul></div>	<div class=top-search><div class=container-search><div class=search-block>
<form id=searchform-header action="https://www.kitguru.net/">
<button class=search-button type=submit value=Search><i class="fa fa-search"></i></button>
<input class=search-live type=text id=s-header name=s title=Search value=Search onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"/>
</form>
</div></div></div>
<div class="social-icons social-colored" style=top:8px>
<a class=ttip-none title=Facebook href="https://www.facebook.com/KitGuru.net/" target=_blank><img src="https://www.kitguru.net/wp-content/themes/sahifa/images/fb_logo.png" alt="#"/></a>
<a class=ttip-none title=Twitter href="http://twitter.com/kitgurupress" target=_blank><img src="https://www.kitguru.net/wp-content/themes/sahifa/images/twittericon.png" alt="#"/></a>
<a class=ttip-none title=Youtube href="https://www.youtube.com/user/KitGuruTech" target=_blank><img src="https://www.kitguru.net/wp-content/themes/sahifa/images/youtube_logo.png" alt="#" style=width:28px /></a>
<a class=ttip-none title=Instagram href="https://www.instagram.com/kitguru_tech/?hl=en" rel=publisher target=_blank style=text-decoration:none><img src="https://www.kitguru.net/wp-content/uploads/2018/11/kg_instagram.jpg" alt="Google+"/></a></li>
</div>
</div>
</div>
</nav>
</header>
<div class="e3lan e3lan-below_header">	<div class="g g-5"><div class="g-single a-2006"><a class=gofollow data-track="MjAwNiw1LDEsMTA=" href="https://seasonic.com/prime-titanium-fanless" target=_blank id=href-ad-2006><img src="https://www.kitguru.net/wp-content/uploads/2020/01/1100x50.gif"/></a></div></div>
</div>
<div id=main-content class=container>
<div class=content>
<div style=position:relative>
<div></div>
</div>
<div xmlns:v="http://rdf.data-vocabulary.org/#" id=crumbs><span typeof=v:Breadcrumb><a rel=v:url property=v:title class=crumbs-home href="https://www.kitguru.net">Home</a></span> <span class=delimiter>/</span> <span typeof=v:Breadcrumb><a rel=v:url property=v:title href="https://www.kitguru.net/category/tech-news/">Tech News</a></span> <span class=delimiter>/</span> <span typeof=v:Breadcrumb><a rel=v:url property=v:title href="https://www.kitguru.net/category/tech-news/featured-tech-news/">Featured Tech News</a></span> <span class=delimiter>/</span> <span class=current>GeIL Launches EVO SPEAR Phantom Gaming Edition DDR4 memory</span></div>
<article class="post-listing post-450641 post type-post status-publish format-standard has-post-thumbnail  category-featured-tech-news category-memory tag-ddr4-memory tag-evo-spear tag-geil tag-news tag-phantom-gaming-edition tag-ram" id=the-post>
<div class=post-inner>
<h1 class="name post-title entry-title"><span itemprop=name>GeIL Launches EVO SPEAR Phantom Gaming Edition DDR4 memory</span></h1>
<p class=post-meta>
<span class=post-meta-author><i class="fa fa-user"></i><a href="https://www.kitguru.net/author/james-dawson/" title="">James Dawson </a></span>
<span class=tie-date><i class="fa fa-clock-o"></i>17 hours ago</span>
<span class=post-cats><i class="fa fa-folder"></i><a href="https://www.kitguru.net/category/tech-news/featured-tech-news/" rel="category tag">Featured Tech News</a>, <a href="https://www.kitguru.net/category/components/memory/" rel="category tag">Memory</a></span>
</p>
<div class=clear></div>
<div class=entry>
<p style=text-align:left></p><p><span style="color:#980000"><strong><em>Golden Emperor International Ltd, the company more commonly known as GeIL has announced the availability from retailers in the Americas of its new EVO SPEAR memory series, sporting the ASRock Phantom Gaming branding.</em></strong></span></p>
<p>GeIL memory and ASRock have joined forces to build a strong foundation for compatibility between motherboard and memory with this new <a href="http://www.geilmemory.com/product/?id=44" target=_blank rel=noopener>EVO SPEAR Phantom Gaming Edition</a> DDR4 memory series. The new memory has been tested under the strict conditions of the ASRock Phantom Gaming validation programme to ensure maximum performance and compatibility levels are achieved.</p>
<p>Thanks to this strict testing and validation process, the GeIL EVO SPEAR Phantom Gaming Edition RAM offers exceptional stability and performance. The EVO SPEAR memory series is available in a frequency ranging from 2400MHz to 3200MHz and in kits of 4GB to 32GB capacity, with voltage ratings of between 1.2v to a maximum of 1.35v.</p>
<p><a href="https://www.kitguru.net/wp-content/uploads/2020/02/FdV4rnGsAk3093Ce.jpg" rel="lightbox[450641]"><img class="alignnone size-large wp-image-450642" src="https://www.kitguru.net/wp-content/uploads/2020/02/FdV4rnGsAk3093Ce-1024x484.jpg" alt="" width=618 height=292 srcset="https://www.kitguru.net/wp-content/uploads/2020/02/FdV4rnGsAk3093Ce-1024x484.jpg 1024w, https://www.kitguru.net/wp-content/uploads/2020/02/FdV4rnGsAk3093Ce-300x142.jpg 300w, https://www.kitguru.net/wp-content/uploads/2020/02/FdV4rnGsAk3093Ce-768x363.jpg 768w" sizes="(max-width: 618px) 100vw, 618px"/></a></p>
<p>EVO SPEAR Phantom Gaming Edition memory modules are built using a 10 layer PCB, housed under a black aluminium heat spreader to provide a stealthy looking appearance, great thermal dissipation and a low profile design means the EVO SPEAR Phantom Gaming RAM is ideal for small form factor gaming systems. GeIL claims the EVO SPEAR series offers the best choice for cost-effective memory in gaming, video editing and 3D animation systems.</p>
<p>GeIL EVO SPEAR is fully compatible with all ASRock Phantom Gaming motherboards including Intel Z390 and AMD X570/X399 platforms as well as a whole range of other AMD AM4 motherboards. A specific variant of EVO SPEAR is optimised for AMD Ryzen processors to guarantee the best compatibility and stability when used in conjunction with AM4 platforms. GeIL has also backed the EVO SPEAR Phantom Gaming Edition memory with a lifetime warranty for peace of mind.</p>
<p>Discuss on our Facebook page <a href="https://www.facebook.com/KitGuru.net/posts/2839749579426195?__xts__%5B0%5D=68.ARD8UPGZ6qTZC6UvC3yqTkE_t8eE7IOXGZZ7-cAn9L-D8r6CEDXqo4giTUqnDAd36GksNpEJsq3B6P7CArZPywcZQnR2HpkNFFHAPdGuv6n1VzRUkCtZBHDAYPufQVFguElQwLZaCh-k4xsHB2bToW7KWZgyXD6nMpsx2KwIhz9bLHqP81zspi4CISTecSnRVr_YPCPeQOKlF4zVLFlgX6M2jp748nI_mNf18s0CIjO2XprgbTdZMh__A4pLhvXJPxoqkpiyAECgesKskiOF4OfIbyKtdLE0khgkGyQwBe6G17fh3T09g0ynUvryVwc4UAH6NVKaYsFxPhoWKqIRVbhC1g&amp;__tn__=-R" target=_blank rel=noopener>HERE</a>.</p>
<p><span style="color:#980000"><strong><em>KitGuru says: Finding the correct memory for AMD platforms is critical for extracting the best possible performance from Ryzen powered platforms, having the confidence to know that the memory will work at a specified speed on AM4 platforms out of the box is very handy. </em></strong></span></p>
<p><a href="https://www.patreon.com/bePatron?u=17187616" data-patreon-widget-type=become-patron-button>Become a Patron!</a><script async src="https://c6.patreon.com/becomePatronButton.bundle.js"></script></p>
<div class="gdrts-rating-block gdrts-align-none gdrts-method-stars-rating gdrts-rating-forbidden gdrts-rating-open  gdrts-item-entity-posts gdrts-item-name-post gdrts-item-id-450641 gdrts-item-itemid-130913">
<div class=gdrts-inner-wrapper>
<div class=gdrts-rating-text>
</div>
<script class=gdrts-rating-data type="application/json">{"item":{"entity":"posts","name":"post","id":450641,"item_id":130913,"nonce":"641c7a73a5"},"render":{"args":{"echo":false,"entity":"posts","name":"post","item_id":null,"id":450641,"method":"stars-rating","series":null},"method":{"disable_rating":false,"allow_super_admin":false,"allow_user_roles":[],"allow_visitor":false,"allow_author":false,"template":"disabled","alignment":"none","responsive":true,"distribution":"normalized","rating":"average","style_type":"font","style_name":"star","style_size":30,"font_color_empty":"#dddddd","font_color_current":"#ffff00","font_color_active":"#dd0000","style_class":"","labels":["Poor","Bad","Good","Great","Excellent"]}},"stars":{"max":5,"resolution":100,"current":0,"char":"s","name":"star","size":30,"type":"font","responsive":true},"labels":["Poor","Bad","Good","Great","Excellent"]}</script>
</div>
</div>
</div>
<div class=share-post>
<span class=share-text>Share</span>
<ul class=flat-social>
<li><a href="https://www.facebook.com/sharer.php?u=https://www.kitguru.net/?p=450641" class=social-facebook rel=external target=_blank><i class="fa fa-facebook"></i> <span>Facebook</span></a></li>
<li><a href="https://twitter.com/intent/tweet?text=GeIL+Launches+EVO+SPEAR+Phantom+Gaming+Edition+DDR4+memory&url=https://www.kitguru.net/?p=450641" class=social-twitter rel=external target=_blank><i class="fa fa-twitter"></i> <span>Twitter</span></a></li>
<li><a href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=https://www.kitguru.net/?p=450641&amp;name=GeIL+Launches+EVO+SPEAR+Phantom+Gaming+Edition+DDR4+memory" class=social-google-plus rel=external target=_blank><i class="fa fa-google-plus"></i> <span>Google +</span></a></li>
<li><a href="https://www.stumbleupon.com/submit?url=https://www.kitguru.net/?p=450641&title=GeIL+Launches+EVO+SPEAR+Phantom+Gaming+Edition+DDR4+memory" class=social-stumble rel=external target=_blank><i class="fa fa-stumbleupon"></i> <span>Stumbleupon</span></a></li>
<li><a href="whatsapp://send?text=GeIL%20Launches%20EVO%20SPEAR%20Phantom%20Gaming%20Edition%20DDR4%20memory https%3A%2F%2Fwww.kitguru.net%2Fcomponents%2Fmemory%2Fjames-dawson%2Fgeil-launches-evo-spear-phantom-gaming-edition-ddr4-memory%2F" class=social-whatsapp rel=external target=_blank><i class="fa fa-whatsapp"></i> <span>Whatsapp</span></a></li>
<li><a href="https://reddit.com/submit?url=https://www.kitguru.net/?p=450641&amp;title=GeIL+Launches+EVO+SPEAR+Phantom+Gaming+Edition+DDR4+memory" class=social-reddit rel=external target=_blank><i class="fa fa-reddit"></i> <span>Reddit</span></a></li>
</ul>
<div class=clear></div>
</div> <div class=clear></div>
</div>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","dateCreated":"2020-02-08T09:38:32+00:00","datePublished":"2020-02-08T09:38:32+00:00","dateModified":"2020-02-08T09:43:34+00:00","headline":"GeIL Launches EVO SPEAR Phantom Gaming Edition DDR4 memory","name":"GeIL Launches EVO SPEAR Phantom Gaming Edition DDR4 memory","keywords":"DDR4 memory,EVO Spear,geil,news,Phantom Gaming Edition,ram","url":"https:\/\/www.kitguru.net\/components\/memory\/james-dawson\/geil-launches-evo-spear-phantom-gaming-edition-ddr4-memory\/","description":"Golden Emperor International Ltd, the company more commonly known as GeIL has announced the availability from retailers in the Americas of its new EVO SPEAR memory series, sporting the ASRock Phantom","copyrightYear":"2020","publisher":{"@id":"#Publisher","@type":"Organization","name":"KitGuru","logo":{"@type":"ImageObject","url":"https:\/\/www.kitguru.net\/wp-content\/uploads\/2017\/01\/kg_logo3.png"},"sameAs":["https:\/\/www.facebook.com\/pages\/KitGuru\/162236020510911?fref=ts","http:\/\/twitter.com\/kitgurupress","https:\/\/www.instagram.com\/kitguru_tech\/?hl=en"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.kitguru.net\/components\/memory\/james-dawson\/geil-launches-evo-spear-phantom-gaming-edition-ddr4-memory\/"},"author":{"@type":"Person","name":"James Dawson","url":"https:\/\/www.kitguru.net\/author\/james-dawson\/"},"articleSection":"Featured Tech News,Memory","articleBody":"Golden Emperor International Ltd, the company more commonly known as GeIL has announced the availability from retailers in the Americas of its new EVO SPEAR memory series, sporting the ASRock Phantom Gaming branding.\r\n\r\nGeIL memory and ASRock have joined forces to build a strong foundation for compatibility between motherboard and memory with this new EVO SPEAR Phantom Gaming Edition DDR4 memory series. The new memory has been tested under the strict conditions of the ASRock Phantom Gaming validation programme to ensure maximum performance and compatibility levels are achieved.\r\n\r\nThanks to this strict testing and validation process, the GeIL EVO SPEAR Phantom Gaming Edition RAM offers exceptional stability and performance. The EVO SPEAR memory series is available in a frequency ranging from 2400MHz to 3200MHz and in kits of 4GB to 32GB capacity, with voltage ratings of between 1.2v to a maximum of 1.35v.\r\n\r\n\r\n\r\nEVO SPEAR Phantom Gaming Edition memory modules are built using a 10 layer PCB, housed under a black aluminium heat spreader to provide a stealthy looking appearance, great thermal dissipation and a low profile design means the EVO SPEAR Phantom Gaming RAM is ideal for small form factor gaming systems. GeIL claims the EVO SPEAR series offers the best choice for cost-effective memory in gaming, video editing and 3D animation systems.\r\n\r\nGeIL EVO SPEAR is fully compatible with all ASRock Phantom Gaming motherboards including Intel Z390 and AMD X570\/X399 platforms as well as a whole range of other AMD AM4 motherboards. A specific variant of EVO SPEAR is optimised for AMD Ryzen processors to guarantee the best compatibility and stability when used in conjunction with AM4 platforms. GeIL has also backed the EVO SPEAR Phantom Gaming Edition memory with a lifetime warranty for peace of mind.\r\n\r\nDiscuss on our Facebook page HERE.\r\n\r\nKitGuru says: Finding the correct memory for AMD platforms is critical for extracting the best possible performance from Ryzen powered platforms, having the confidence to know that the memory will work at a specified speed on AM4 platforms out of the box is very handy. ","image":{"@type":"ImageObject","url":"https:\/\/www.kitguru.net\/wp-content\/uploads\/2020\/02\/MjFr96vJmwRb7hI5.jpg","width":1440,"height":960}}</script>
</article>
<p class=post-tag>Tags <a href="https://www.kitguru.net/tag/ddr4-memory/" rel=tag>DDR4 memory</a> <a href="https://www.kitguru.net/tag/evo-spear/" rel=tag>EVO Spear</a> <a href="https://www.kitguru.net/tag/geil/" rel=tag>geil</a> <a href="https://www.kitguru.net/tag/news/" rel=tag>news</a> <a href="https://www.kitguru.net/tag/phantom-gaming-edition/" rel=tag>Phantom Gaming Edition</a> <a href="https://www.kitguru.net/tag/ram/" rel=tag>ram</a></p>
<div class="e3lan e3lan-post">	</div>
<div class=post-navigation>
<div class=post-previous><a href="https://www.kitguru.net/gaming/matthew-wilson/cyberpunk-2077-will-feature-plenty-of-handcrafted-side-quests/" rel=prev><span>Previous</span> Cyberpunk 2077 will feature plenty of handcrafted side quests</a></div>
<div class=post-next><a href="https://www.kitguru.net/tech-news/featured-tech-news/james-dawson/turtle-beach-adds-new-colour-options-to-its-recon-70-affordable-headset-series/" rel=next><span>Next</span> Turtle Beach adds new colour options to its Recon 70 affordable headset series</a></div>
</div>
<section id=check-also-box class="post-listing check-also-right">
<a href="#" id=check-also-close><i class="fa fa-close"></i></a>
<div class=block-head>
<h3>Check Also</h3>
</div>
<div class=check-also-post>
<div class=post-thumbnail>
<a href="https://www.kitguru.net/tech-news/featured-tech-news/james-dawson/master-dynamic-update-its-mw07-plus-true-wireless-earphones-range/">
<img width=310 height=165 src="https://www.kitguru.net/wp-content/uploads/2020/02/MW07PLUSBP_Angle_Right_800x800-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt=""/>	<span class="fa overlay-icon"></span>
</a>
</div>
<h2 class=post-title><a href="https://www.kitguru.net/tech-news/featured-tech-news/james-dawson/master-dynamic-update-its-mw07-plus-true-wireless-earphones-range/" rel=bookmark>Master &#038; Dynamic updates its MW07 PLUS True Wireless Earphones range</a></h2>
<p>New York based audio brand, Master &amp; Dynamic has announced two new colour versions of &hellip;</p>
</div>
</section>
<div id=disqus_thread></div>
</div>
<aside id=sidebar>
<div class=theiaStickySidebar>
<div id=text-7 class="widget widget_text"><div class=widget-top><h4> </h4><div class=stripe-line></div></div>
<div class=widget-container>	<div class=textwidget><div class="g g-14"><div class="g-single a-2086"><a class=gofollow data-track=MjA4NiwxNCwxLDEw href="https://www.kitguru.net/news/best-pc-hardware/" target=_blank id=href-ad-2086><img src="https://www.kitguru.net/wp-content/uploads/2019/04/KITGURU-Best-of-The-Enthusiasts-Shortlist.jpg"/></a></div></div>
<select id=top-5-dropdown class=select-css onchange="if(this.value!=''){window.location.assign(window.location.protocol + '://' + window.location.hostname + this.value)};">
<option value="">I&#8217;m in the market for a new&#8230;</option>
<option value="/news/best-pc-hardware/best-case-2020/">Case</option>
<option value="/news/best-pc-hardware/best-cooler-2020/">Coolers</option>
<option value="/news/best-pc-hardware/best-desktop-pc-2020/">Desktop</option>
<option value="/news/best-pc-hardware/best-gaming-furniture-2020/">Gaming Furniture</option>
<option value="/news/best-pc-hardware/best-graphics-card-2020/">Graphics Card</option>
<option value="/news/best-pc-hardware/best-hard-disk-drive-hdd-2020/">HDD</option>
<option value="/news/best-pc-hardware/best-headset-2020/">Headset</option>
<option value="/news/best-pc-hardware/best-keyboard-2020/">Keyboards</option>
<option value="/news/best-pc-hardware/best-laptop-2020/">Laptop</option>
<option value="/news/best-pc-hardware/best-memory-2020/">Memory</option>
<option value="/news/best-pc-hardware/best-monitor-2020/">Monitors</option>
<option value="/news/best-pc-hardware/best-motherboard-2020/">Motherboard</option>
<option value="/news/best-pc-hardware/best-mouse-2020/">Mouse</option>
<option value="/news/best-pc-hardware/best-nas-2020/">NAS</option>
<option value="/news/best-pc-hardware/best-power-supply-2020/">Power Supply</option>
<option value="/news/best-pc-hardware/best-processor-2020/">Processor</option>
<option value="/news/best-pc-hardware/best-router-2020/">Router</option>
<option value="/news/best-pc-hardware/best-solid-state-drive-ssd-2020/">SSD</option>
<option value="/news/best-pc-hardware/best-speakers-2020/">Speakers</option>
<option value="/news/best-pc-hardware/best-workstation-2020/">Workstation</option>
</select></div>
</div></div><div id=text-3 class="widget widget_text"><div class=widget-top><h4> </h4><div class=stripe-line></div></div>
<div class=widget-container>	<div class=textwidget><div class="g g-1"><div class="g-single a-2153">
<a class=gofollow data-track="MjE1MywxLDEsMTA=" href="https://servedbyadbutler.com/go2/;ID=170743;size=300x250;setID=344031" target=_blank><img src="https://servedbyadbutler.com/adserve/;ID=170743;size=300x250;setID=344031;type=img;click=CLICK_MACRO_PLACEHOLDER" width=300 height=250></a></div></div></div>
</div></div><div id=text-8 class="widget widget_text"><div class=widget-top><h4> </h4><div class=stripe-line></div></div>
<div class=widget-container>	<div class=textwidget><div class="g g-15"><div class="g-single a-2257"><a class=gofollow data-track=MjI1NywxNSwxLDEw href="https://www.overclockers.co.uk/?utm_source=kitguru&utm_medium=referral&utm_campaign=generic-banner-300x70&utm_content=02190113-generic-generic" target=_blank id=href-ad-2257><img src="https://www.kitguru.net/wp-content/uploads/2020/01/OCUK-Jan-300x70.png"/></a></div></div></div>
</div></div><div id=text-9 class="widget widget_text"><div class=widget-top><h4> </h4><div class=stripe-line></div></div>
<div class=widget-container>	<div class=textwidget><div class="g g-16"><div class="g-single a-2249"><a class=gofollow data-track=MjI0OSwxNiwxLDEw href="https://msi.gm/Alpha-15-A3DX-UK" target=_blank id=href-ad-2249><img src="https://www.kitguru.net/wp-content/uploads/2019/12/MSI-Dec-70.gif"/></a></div></div></div>
</div></div><div id=text-11 class="widget widget_text"><div class=widget-top><h4> </h4><div class=stripe-line></div></div>
<div class=widget-container>	<div class=textwidget><div class="g g-18"><div class="g-single a-2025"><a class=gofollow data-track=MjAyNSwxOCwxLDEw href="http://www.arctic.ac/liquidfreezer2/" target=_blank id=href-ad-2025><img src="https://www.kitguru.net/wp-content/uploads/2019/10/ARCTIC_Permaspot_Liquid_Freezer_II_300x70.png"/></a></div></div></div>
</div></div><div id=text-12 class="widget widget_text"><div class=widget-top><h4> </h4><div class=stripe-line></div></div>
<div class=widget-container>	<div class=textwidget></div>
</div></div><div id=text-13 class="widget widget_text"><div class=widget-top><h4> </h4><div class=stripe-line></div></div>
<div class=widget-container>	<div class=textwidget></div>
</div></div><div id=text-4 class="widget widget_text"><div class=widget-top><h4> </h4><div class=stripe-line></div></div>
<div class=widget-container>	<div class=textwidget><div class="g g-3"><div class="g-single a-2286"><a class=gofollow data-track="MjI4NiwzLDEsMTA=" href="https://cougargaming.com/products/cases/darkblader-g/" target=_blank id=href-ad-2286><img src="https://www.kitguru.net/wp-content/uploads/2020/01/DarkbladerG-300x250.png"/></a></div></div></div>
</div></div><div id=polls-widget-3 class="widget widget_polls-widget"><div class=widget-top><h4>Polls</h4><div class=stripe-line></div></div>
<div class=widget-container><div id=polls-173 class=wp-polls>
<form id=polls_form_173 class=wp-polls-form action="/index.php" method=post>
<p style=display:none><input type=hidden id=poll_173_nonce name=wp-polls-nonce value=4c1086f4df /></p>
<p style=display:none><input type=hidden name=poll_id value=173 /></p>
<p style=text-align:center><strong>Next desktop monitor refresh rate?</strong></p><div id=polls-173-ans class=wp-polls-ans><ul class=wp-polls-ul>
<li><input type=radio id=poll-answer-1101 name=poll_173 value=1101 /> <label for=poll-answer-1101>60/75Hz is fine</label></li>
<li><input type=radio id=poll-answer-1102 name=poll_173 value=1102 /> <label for=poll-answer-1102>120/144/165Hz for me</label></li>
<li><input type=radio id=poll-answer-1103 name=poll_173 value=1103 /> <label for=poll-answer-1103>I want at least 200Hz</label></li>
<li><input type=radio id=poll-answer-1104 name=poll_173 value=1104 /> <label for=poll-answer-1104>I've seen 360Hz and want it</label></li>
<li><input type=radio id=poll-answer-1105 name=poll_173 value=1105 /> <label for=poll-answer-1105>Don't care about refresh - just give me SIZE</label></li>
</ul><p style=text-align:center><input type=button name=vote value="   Vote   " class=Buttons onclick="poll_vote(173);"/></p><p style=text-align:center><a href="#ViewPollResults" onclick="poll_result(173); return false;" title="View Results Of This Poll">View Results</a></p></div>
</form>
</div>
<div id=polls-173-loading class=wp-polls-loading><img src="https://www.kitguru.net/wp-content/plugins/wp-polls/images/loading.gif" width=16 height=16 alt="Loading ..." title="Loading ..." class=wp-polls-image />&nbsp;Loading ...</div>
</div></div><div id=text-5 class="widget widget_text"><div class=widget-top><h4> </h4><div class=stripe-line></div></div>
<div class=widget-container>	<div class=textwidget><div class="g g-4"><div class="g-single a-2265"><a class=gofollow data-track="MjI2NSw0LDEsMTA=" href="https://www.sapphirenation.net/get-monster-hunter-world_iceborne-master-edition_bundle-with-rx-5500-series" target=_blank id=href-ad-2265><img src="https://www.kitguru.net/wp-content/uploads/2020/01/MHW_V2_rx5500xt_XboxPass_300x250_en.jpg"/></a></div></div></div>
</div></div><div id=text-6 class="widget widget_text"><div class=widget-top><h4> </h4><div class=stripe-line></div></div>
<div class=widget-container>	<div class=textwidget><div class="g g-6"><div class="g-single a-2292"><a class=gofollow data-track="MjI5Miw2LDEsMTA=" href="https://www.overclockers.co.uk/cooler-master-masterliquid-ml240p-mirage-argb-aio-cpu-cooler-free-masterfan-sf240r-argb-fans-bu-019-cm.html" target=_blank id=href-ad-2292><img src="https://www.kitguru.net/wp-content/uploads/2020/02/Cooler-Master-MPU-300-February-2020.jpg"/></a></div></div></div>
</div></div><div id=text-10 class="widget widget_text"><div class=widget-top><h4> </h4><div class=stripe-line></div></div>
<div class=widget-container>	<div class=textwidget><div class="g g-17"><div class="g-single a-2005"><a class=gofollow data-track=MjAwNSwxNywxLDEw href="https://seasonic.com/prime-titanium-fanless" target=_blank id=href-ad-2005><img src="https://www.kitguru.net/wp-content/uploads/2020/01/300x250.gif"/></a></div></div></div>
</div></div><div id=archives-3 class="widget widget_archive"><div class=widget-top><h4>Archives</h4><div class=stripe-line></div></div>
<div class=widget-container>	<label class=screen-reader-text for=archives-dropdown-3>Archives</label>
<select id=archives-dropdown-3 name=archive-dropdown onchange='document.location.href=this.options[this.selectedIndex].value;'>
<option value="">Select Month</option>
<option value='https://www.kitguru.net/2020/02/'> February 2020 </option>
<option value='https://www.kitguru.net/2020/01/'> January 2020 </option>
<option value='https://www.kitguru.net/2019/12/'> December 2019 </option>
<option value='https://www.kitguru.net/2019/11/'> November 2019 </option>
<option value='https://www.kitguru.net/2019/10/'> October 2019 </option>
<option value='https://www.kitguru.net/2019/09/'> September 2019 </option>
<option value='https://www.kitguru.net/2019/08/'> August 2019 </option>
<option value='https://www.kitguru.net/2019/07/'> July 2019 </option>
<option value='https://www.kitguru.net/2019/06/'> June 2019 </option>
<option value='https://www.kitguru.net/2019/05/'> May 2019 </option>
<option value='https://www.kitguru.net/2019/04/'> April 2019 </option>
<option value='https://www.kitguru.net/2019/03/'> March 2019 </option>
<option value='https://www.kitguru.net/2019/02/'> February 2019 </option>
<option value='https://www.kitguru.net/2019/01/'> January 2019 </option>
<option value='https://www.kitguru.net/2018/12/'> December 2018 </option>
<option value='https://www.kitguru.net/2018/11/'> November 2018 </option>
<option value='https://www.kitguru.net/2018/10/'> October 2018 </option>
<option value='https://www.kitguru.net/2018/09/'> September 2018 </option>
<option value='https://www.kitguru.net/2018/08/'> August 2018 </option>
<option value='https://www.kitguru.net/2018/07/'> July 2018 </option>
<option value='https://www.kitguru.net/2018/06/'> June 2018 </option>
<option value='https://www.kitguru.net/2018/05/'> May 2018 </option>
<option value='https://www.kitguru.net/2018/04/'> April 2018 </option>
<option value='https://www.kitguru.net/2018/03/'> March 2018 </option>
<option value='https://www.kitguru.net/2018/02/'> February 2018 </option>
<option value='https://www.kitguru.net/2018/01/'> January 2018 </option>
<option value='https://www.kitguru.net/2017/12/'> December 2017 </option>
<option value='https://www.kitguru.net/2017/11/'> November 2017 </option>
<option value='https://www.kitguru.net/2017/10/'> October 2017 </option>
<option value='https://www.kitguru.net/2017/09/'> September 2017 </option>
<option value='https://www.kitguru.net/2017/08/'> August 2017 </option>
<option value='https://www.kitguru.net/2017/07/'> July 2017 </option>
<option value='https://www.kitguru.net/2017/06/'> June 2017 </option>
<option value='https://www.kitguru.net/2017/05/'> May 2017 </option>
<option value='https://www.kitguru.net/2017/04/'> April 2017 </option>
<option value='https://www.kitguru.net/2017/03/'> March 2017 </option>
<option value='https://www.kitguru.net/2017/02/'> February 2017 </option>
<option value='https://www.kitguru.net/2017/01/'> January 2017 </option>
<option value='https://www.kitguru.net/2016/12/'> December 2016 </option>
<option value='https://www.kitguru.net/2016/11/'> November 2016 </option>
<option value='https://www.kitguru.net/2016/10/'> October 2016 </option>
<option value='https://www.kitguru.net/2016/09/'> September 2016 </option>
<option value='https://www.kitguru.net/2016/08/'> August 2016 </option>
<option value='https://www.kitguru.net/2016/07/'> July 2016 </option>
<option value='https://www.kitguru.net/2016/06/'> June 2016 </option>
<option value='https://www.kitguru.net/2016/05/'> May 2016 </option>
<option value='https://www.kitguru.net/2016/04/'> April 2016 </option>
<option value='https://www.kitguru.net/2016/03/'> March 2016 </option>
<option value='https://www.kitguru.net/2016/02/'> February 2016 </option>
<option value='https://www.kitguru.net/2016/01/'> January 2016 </option>
<option value='https://www.kitguru.net/2015/12/'> December 2015 </option>
<option value='https://www.kitguru.net/2015/11/'> November 2015 </option>
<option value='https://www.kitguru.net/2015/10/'> October 2015 </option>
<option value='https://www.kitguru.net/2015/09/'> September 2015 </option>
<option value='https://www.kitguru.net/2015/08/'> August 2015 </option>
<option value='https://www.kitguru.net/2015/07/'> July 2015 </option>
<option value='https://www.kitguru.net/2015/06/'> June 2015 </option>
<option value='https://www.kitguru.net/2015/05/'> May 2015 </option>
<option value='https://www.kitguru.net/2015/04/'> April 2015 </option>
<option value='https://www.kitguru.net/2015/03/'> March 2015 </option>
<option value='https://www.kitguru.net/2015/02/'> February 2015 </option>
<option value='https://www.kitguru.net/2015/01/'> January 2015 </option>
<option value='https://www.kitguru.net/2014/12/'> December 2014 </option>
<option value='https://www.kitguru.net/2014/11/'> November 2014 </option>
<option value='https://www.kitguru.net/2014/10/'> October 2014 </option>
<option value='https://www.kitguru.net/2014/09/'> September 2014 </option>
<option value='https://www.kitguru.net/2014/08/'> August 2014 </option>
<option value='https://www.kitguru.net/2014/07/'> July 2014 </option>
<option value='https://www.kitguru.net/2014/06/'> June 2014 </option>
<option value='https://www.kitguru.net/2014/05/'> May 2014 </option>
<option value='https://www.kitguru.net/2014/04/'> April 2014 </option>
<option value='https://www.kitguru.net/2014/03/'> March 2014 </option>
<option value='https://www.kitguru.net/2014/02/'> February 2014 </option>
<option value='https://www.kitguru.net/2014/01/'> January 2014 </option>
<option value='https://www.kitguru.net/2013/12/'> December 2013 </option>
<option value='https://www.kitguru.net/2013/11/'> November 2013 </option>
<option value='https://www.kitguru.net/2013/10/'> October 2013 </option>
<option value='https://www.kitguru.net/2013/09/'> September 2013 </option>
<option value='https://www.kitguru.net/2013/08/'> August 2013 </option>
<option value='https://www.kitguru.net/2013/07/'> July 2013 </option>
<option value='https://www.kitguru.net/2013/06/'> June 2013 </option>
<option value='https://www.kitguru.net/2013/05/'> May 2013 </option>
<option value='https://www.kitguru.net/2013/04/'> April 2013 </option>
<option value='https://www.kitguru.net/2013/03/'> March 2013 </option>
<option value='https://www.kitguru.net/2013/02/'> February 2013 </option>
<option value='https://www.kitguru.net/2013/01/'> January 2013 </option>
<option value='https://www.kitguru.net/2012/12/'> December 2012 </option>
<option value='https://www.kitguru.net/2012/11/'> November 2012 </option>
<option value='https://www.kitguru.net/2012/10/'> October 2012 </option>
<option value='https://www.kitguru.net/2012/09/'> September 2012 </option>
<option value='https://www.kitguru.net/2012/08/'> August 2012 </option>
<option value='https://www.kitguru.net/2012/07/'> July 2012 </option>
<option value='https://www.kitguru.net/2012/06/'> June 2012 </option>
<option value='https://www.kitguru.net/2012/05/'> May 2012 </option>
<option value='https://www.kitguru.net/2012/04/'> April 2012 </option>
<option value='https://www.kitguru.net/2012/03/'> March 2012 </option>
<option value='https://www.kitguru.net/2012/02/'> February 2012 </option>
<option value='https://www.kitguru.net/2012/01/'> January 2012 </option>
<option value='https://www.kitguru.net/2011/12/'> December 2011 </option>
<option value='https://www.kitguru.net/2011/11/'> November 2011 </option>
<option value='https://www.kitguru.net/2011/10/'> October 2011 </option>
<option value='https://www.kitguru.net/2011/09/'> September 2011 </option>
<option value='https://www.kitguru.net/2011/08/'> August 2011 </option>
<option value='https://www.kitguru.net/2011/07/'> July 2011 </option>
<option value='https://www.kitguru.net/2011/06/'> June 2011 </option>
<option value='https://www.kitguru.net/2011/05/'> May 2011 </option>
<option value='https://www.kitguru.net/2011/04/'> April 2011 </option>
<option value='https://www.kitguru.net/2011/03/'> March 2011 </option>
<option value='https://www.kitguru.net/2011/02/'> February 2011 </option>
<option value='https://www.kitguru.net/2011/01/'> January 2011 </option>
<option value='https://www.kitguru.net/2010/12/'> December 2010 </option>
<option value='https://www.kitguru.net/2010/11/'> November 2010 </option>
<option value='https://www.kitguru.net/2010/10/'> October 2010 </option>
<option value='https://www.kitguru.net/2010/09/'> September 2010 </option>
<option value='https://www.kitguru.net/2010/08/'> August 2010 </option>
<option value='https://www.kitguru.net/2010/07/'> July 2010 </option>
<option value='https://www.kitguru.net/2010/06/'> June 2010 </option>
<option value='https://www.kitguru.net/2010/05/'> May 2010 </option>
<option value='https://www.kitguru.net/2010/04/'> April 2010 </option>
<option value='https://www.kitguru.net/2010/03/'> March 2010 </option>
</select>
</div></div><div id=text-16 class="widget widget_text"><div class=widget-top><h4> </h4><div class=stripe-line></div></div>
<div class=widget-container>	<div class=textwidget><div class="g g-52"><div class="g-single a-2256"><a class=gofollow data-track=MjI1Niw1MiwxLDEw href="https://www.overclockers.co.uk/?utm_source=kitguru&utm_medium=referral&utm_campaign=generic-banner-300x250&utm_content=02190113-generic-generic" target=_blank id=href-ad-2256><img src="https://www.kitguru.net/wp-content/uploads/2020/01/OCUK-Jan-300x250.png"/></a></div></div></div>
</div></div>	</div>
</aside>	<div class=clear></div>
</div>
<footer id=theme-footer>
<div id=footer-widget-area class=footer-3c>
<div id=footer-second class=footer-widgets-box>
<div id=text-15 class="footer-widget widget_text"><div class=footer-widget-top><h4> </h4></div>
<div class=footer-widget-container>	<div class=textwidget><div class="g g-51"><div class="g-single a-2275"><a class=gofollow data-track=MjI3NSw1MSwxLDEw href="https://www.alternate.co.uk/Sharkoon/Light-200-Mouse/html/product/1590461" target=_blank id=href-ad-2275><img src="https://www.kitguru.net/wp-content/uploads/2020/01/Sharkoon_Light2_200_728x90.jpg"/></a></div></div></div>
</div></div>	</div>
</div>
<div class=clear></div>
</footer>
<div class=clear></div>
<div class=footer-bottom>
<div class=container>
<div class=alignright>
<div style=float:left> <a href="https://www.kitguru.net/contact">Contact Us</a>  <a href="https://www.kitguru.net/privacy">Privacy</a></div>	</div>
<div class=social-icons>
<a class=ttip-none title=Rss href="https://www.kitguru.net/feed/" target=_blank><i class="fa fa-rss"></i></a><a class=ttip-none title=Facebook href="https://www.facebook.com/pages/KitGuru/162236020510911?fref=ts" target=_blank><i class="fa fa-facebook"></i></a><a class=ttip-none title=Twitter href="http://twitter.com/kitgurupress" target=_blank><i class="fa fa-twitter"></i></a><a class=ttip-none title=instagram href="https://www.instagram.com/kitguru_tech/?hl=en" target=_blank><i class="fa fa-instagram"></i></a>
</div>
<div class=alignleft>
<div style=float:left>© Copyright 2020, Kitguru.net All Rights Reserved <a href="https://www.kitguru.net/standardterms/"> Standard Terms</a></div>
</div>
<div class=clear></div>
</div>
</div>
</div>
</div>
</div>
<div id=topcontrol class="fa fa-angle-up" title="Scroll To Top"></div>
<div id=fb-root></div>
<script>
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script>
var pageTracker = _gat._getTracker("UA-15867468-1");
pageTracker._initData();
pageTracker._trackPageview();
</script>
<div id=reading-position-indicator></div><script src='https://www.kitguru.net/,qkitguru_wrapjs=1.pagespeed.ce.4ytk0nQYPx.js'></script>
<script>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/www.kitguru.net\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script src='https://www.kitguru.net/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script>
/* <![CDATA[ */
var countVars = {"disqusShortname":"kitguru"};
/* ]]> */
</script>
<script src='https://www.kitguru.net/wp-content/plugins/disqus-comment-system/public/js/comment_count.js'></script>
<script>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"450641 https:\/\/www.kitguru.net\/?p=450641","disqusShortname":"kitguru","disqusTitle":"GeIL Launches EVO SPEAR Phantom Gaming Edition DDR4 memory","disqusUrl":"https:\/\/www.kitguru.net\/components\/memory\/james-dawson\/geil-launches-evo-spear-phantom-gaming-edition-ddr4-memory\/","postId":"450641"};
/* ]]> */
</script>
<script src='https://www.kitguru.net/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js'></script>
<script>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.kitguru.net\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script src='https://www.kitguru.net/wp-content/plugins/wp-polls/polls-js.js'></script>
<script src='https://www.kitguru.net/wp-content/plugins/gd-rating-system/addons/tooltip/js/tooltip.js'></script>
<script>
/* <![CDATA[ */
var gdrts_rating_data = {"url":"https:\/\/www.kitguru.net\/wp-admin\/admin-ajax.php","nonce":"025848e203","user":"0","handler":"gdrts_live_handler","ajax_error":"console","wp_version":"49"};
/* ]]> */
</script>
<script src='https://www.kitguru.net/wp-content/plugins/gd-rating-system/js/rating.min.js'></script>
<script>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"1","is_singular":"1","SmothScroll":"true","reading_indicator":"true","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script src='https://www.kitguru.net/wp-content/themes/sahifa/js/tie-scripts.js'></script>
<script src='https://www.kitguru.net/wp-content/themes/sahifa/js/ilightbox.packed.js'></script>
<script src='https://www.kitguru.net/wp-content/plugins/page-links-to/dist/new-tab.js'></script>
<script src='https://www.kitguru.net/wp-includes/js/wp-embed.min.js'></script>
<script src='https://www.kitguru.net/wp-content/themes/sahifa/js/search.js'></script>
<script>
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script>
try {
var pageTracker = _gat._getTracker("UA-15867468-1");
pageTracker._setDomainName(".kitguru.net");
pageTracker._trackPageview();
} catch(err) {}</script>
<noscript class=psa_add_styles><link rel=stylesheet id=alek_hacks_overrides-css href='https://www.kitguru.net/wp-content/plugins/alek_mpu/overrides.css' type='text/css' media=all data-pagespeed-lsc-url="https://www.kitguru.net/wp-content/plugins/alek_mpu/overrides.css"/><link rel=stylesheet id=tie-insta-style-css href='https://www.kitguru.net/wp-content/plugins/instagramy/assets/style.css' type='text/css' media=all data-pagespeed-lsc-url="https://www.kitguru.net/wp-content/plugins/instagramy/assets/style.css"/><link rel=stylesheet id=wp-polls-css href='https://www.kitguru.net/wp-content/plugins/wp-polls/polls-css.css' type='text/css' media=all data-pagespeed-lsc-url="https://www.kitguru.net/wp-content/plugins/wp-polls/polls-css.css"/><style id=wp-polls-inline-css>.wp-polls .pollbar{margin:1px;font-size:6px;line-height:8px;height:8px;background-image:url(https://www.kitguru.net/wp-content/plugins/wp-polls/images/default/pollbg.gif);border:1px solid #c8c8c8}</style><link rel=stylesheet id=gdrts-gridism-css href='https://www.kitguru.net/wp-content/plugins/gd-rating-system/css/gridism.css' type='text/css' media=all data-pagespeed-lsc-url="https://www.kitguru.net/wp-content/plugins/gd-rating-system/css/gridism.css"/><link rel=stylesheet id=gdrts-rating-css href='https://www.kitguru.net/wp-content/plugins/gd-rating-system/css/A.rating.min.css.pagespeed.cf.nWHvpTXofq.css' type='text/css' media=all data-pagespeed-lsc-url="https://www.kitguru.net/wp-content/plugins/gd-rating-system/css/rating.min.css"/><link rel=stylesheet id=gdrts-font-css href='https://www.kitguru.net/wp-content/plugins/gd-rating-system/font/default.min.css' type='text/css' media=all data-pagespeed-lsc-url="https://www.kitguru.net/wp-content/plugins/gd-rating-system/font/default.min.css"/><link rel=stylesheet id=gdrts-tooltip-css href='https://www.kitguru.net/wp-content/plugins/gd-rating-system/addons/tooltip/css/tooltip.css' type='text/css' media=all data-pagespeed-lsc-url="https://www.kitguru.net/wp-content/plugins/gd-rating-system/addons/tooltip/css/tooltip.css"/><link rel=stylesheet id=tie-style-css href='https://www.kitguru.net/wp-content/themes/sahifa/style.css' type='text/css' media=all data-pagespeed-lsc-url="https://www.kitguru.net/wp-content/themes/sahifa/style.css"/><link rel=stylesheet id=tie-ilightbox-skin-css href='https://www.kitguru.net/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media=all data-pagespeed-lsc-url="https://www.kitguru.net/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css"/><link rel=stylesheet id='Open+Sans-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic' type='text/css' media=all /><link rel=stylesheet id='Droid+Sans-css' href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media=all /><link rel=stylesheet id=js_composer_custom_css-css href='//www.kitguru.net/wp-content/uploads/js_composer/custom.css' type='text/css' media=all data-pagespeed-lsc-url="https://www.kitguru.net/wp-content/uploads/js_composer/custom.css"/><style media=screen>.g{margin:0;padding:0;overflow:hidden;line-height:1;zoom:1}.g img{height:auto}.g-col{position:relative;float:left}.g-col:first-child{margin-left:0}.g-col:last-child{margin-right:0}.g-1{margin:1px;1px 1px 1px}.g-2{margin:1px;1px 1px 1px}.g-3{margin:1px;1px 1px 1px}.g-4{margin:1px;1px 1px 1px}.g-5{margin:1px 1px 1px 1px}.g-6{margin:1px;1px 1px 1px}.g-7{margin:1px 1px 1px 1px}.g-8{margin:1px 1px 1px 1px}.g-10{margin:1px 1px 1px 1px}.g-11{margin:1px 1px 1px 1px}.g-12{margin:1px 1px 1px 1px}.g-13{margin:1px 1px 1px 1px}.g-14{margin:1px 1px 1px 1px}.g-15{margin:1px 1px 1px 1px}.g-16{margin:1px 1px 1px 1px}.g-17{margin:1px;1px 1px 1px}.g-18{margin:1px 1px 1px 1px}.g-19{margin:1px 1px 1px 1px}.g-20{margin:1px 1px 1px 1px}.g-21{margin:1px 1px 1px 1px}.g-22{margin:1px 1px 1px 1px}.g-30{margin:0 0 6px 0}.g-52{margin:1px;1px 1px 1px}@media only screen and (max-width:480px){.g-col,.g-dyn,.g-single{width:100%;margin-left:0;margin-right:0}}</style><link rel=stylesheet href="https://www.kitguru.net/wp-content/plugins/search-engine-query-in-wordpress-related-contents/seq_in_wp.css" type="text/css" data-pagespeed-lsc-url="https://www.kitguru.net/wp-content/plugins/search-engine-query-in-wordpress-related-contents/seq_in_wp.css"/><link rel=stylesheet type="text/css" href="https://www.kitguru.net/wp-content/plugins/star-rating-for-reviews/star-rating.css" data-pagespeed-lsc-url="https://www.kitguru.net/wp-content/plugins/star-rating-for-reviews/star-rating.css"/><style media=screen>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</style><style>#wpadminbar #wp-admin-bar-gdrts-toolbar .ab-icon:before{content:"\f155";top:2px}@media screen and (max-width:782px ){#wpadminbar li#wp-admin-bar-gdrts-toolbar{display:block}}</style></noscript><noscript><style>.wpb_animate_when_almost_visible{opacity:1}</style></noscript><script data-pagespeed-no-defer>//<![CDATA[
(function(){function b(){var a=window,c=e;if(a.addEventListener)a.addEventListener("load",c,!1);else if(a.attachEvent)a.attachEvent("onload",c);else{var d=a.onload;a.onload=function(){c.call(this);d&&d.call(this)}}};var f=!1;function e(){if(!f){f=!0;for(var a=document.getElementsByClassName("psa_add_styles"),c=0,d;d=a[c];++c)if("NOSCRIPT"==d.nodeName){var k=document.createElement("div");k.innerHTML=d.textContent;document.body.appendChild(k)}}}function g(){var a=window.requestAnimationFrame||window.webkitRequestAnimationFrame||window.mozRequestAnimationFrame||window.oRequestAnimationFrame||window.msRequestAnimationFrame||null;a?a(function(){window.setTimeout(e,0)}):b()}
var h=["pagespeed","CriticalCssLoader","Run"],l=this;h[0]in l||!l.execScript||l.execScript("var "+h[0]);for(var m;h.length&&(m=h.shift());)h.length||void 0===g?l[m]?l=l[m]:l=l[m]={}:l[m]=g;})();
pagespeed.CriticalCssLoader.Run();
//]]></script></body>
</html>